On: 2006/01/19 Viewed: 434270 times
Shorter URL for this page: http://ozh.in/kl

One of the first things I wanted to improve in the admin area of my WordPress blog, back in the 1.5 days, was the header menu. I wanted to be able to reach any admin page in one click, instead of first clicking on the first level link ("Manage" for example) and then only on a submenu link ("Comments") So came a very neat plugin : the WordPress Admin Drop Down Menu

When WordPress 2.7 and its new and optimized user interface came, I thought there was still room for improvements: a horizontal menu gave the admin area more of a "desktop application" feel, and I think it's superior to a vertical menu. So I updated the WordPress Admin Drop Down Menu.

Download

Get the plugin :

Download the plugin :
ozh-admin-drop-down-menu.zip
Extract and upload to your blog, preserving directory structure.
Note: download counter here and stats on wordpress.org may differ and reflect the number of downloads before this plugin was hosted on the plugin directory

Activate and enjoy. Another friendly install & forget piece of PHP.

Features

  • Customizable color scheme with a neat color picker
  • Normal mode for regular users, compact mode for real estate maniacs, minimal mode for those who never have enough
  • Optional cute icons from FamFamFam
  • Enhanced compatibility with handheld devices
  • Joy and happiness for every day

Javascript is involved for advanced features and to make stuff compatible with MSIE6, but on any decent browser everything works even with Javascript disabled.

Super neat color picking.

Any color you'll love.

Normal or compact display.

Browser compatibility

The plugin has been developed on Firefox 3, Chrome and MSIE7. It should do fine with MSIE6 and Safari too.

There are glitches with Firefox 2 and Camino which both use a deprecated rendering engine. There are also glitches with Opera. I won't fix these, but if anyone wants to submit a CSS patch to resolve one of these issue, you're welcome :)

Developer friendly

The plugin comes with a wickedly cool API that will allow other plugin developers to interact with it, like adding your own custom icon for your plugin. Read the API for Coders page for examples and documentation. Also, all elements the plugin produces get custom CSS classes and id's to allow easy styling or selecting.

Translations

The plugin is ready for interglobanalization and there is a .pot template file included so polyglots can even make their own translation and sent the .mo and .po files to me that I'll include in the package.

The plugin comes with the following translations, in no particular order:

And maybe more since I might totally forget to update this list :)

Older Versions

All my plugins are designed to run on the latest WordPress version available. Upgrade WordPress whenever a new version is out, or be sorry when your site gets compromised.

If for some unintelligent reason you need to get an older version of this plugin, it might be available, yet totally unsupported or recommended. Check here: Other versions.

Feedback, Bug report, Feature request

Sure. Feed me back. Like it? Blog about it. Love it? Click on the download link, see the Paypal button appear, and give it some clicks!

If you're reporting bugs, you're welcome, but please provide a screenshot and informations about your browser & your OS. I'm not supporting deprecated blogs or plugins or browsers, and I can't respond to incomplete bug reports.

If you're suggesting a feature, you're welcome too, but I won't add an admin menu on the public side of the blog, on top of pages. If you're looking after having this menu fixed on top of page, check this companion plugin that works as a plugin to this plugin: Admin Menus Fixed.

Shorter URL

Want to share or tweet this page? Please use this short URL: http://ozh.in/kl

Metastuff

This page "WordPress Plugin : Admin Drop Down Menu" was posted on 19/01/2006 at 10:28 am
Watch this discussion : Comments RSS 2.0.

1,637 Blablas

    Pages: « 122 23 24 25 26 [27] 28 29 30 31 3233 » Show All

  1. 1301
    Aaqil Pakistan »
    wrote, on 17/May/10 at 3:15 am # :

    Thank you so much that's even compatible for urdu farsi arabic

  2. 1302
    steve United Kingdom »
    commented, on 27/May/10 at 1:43 pm # :

    Hi,
    This is one plugin I've grown to love – its 100% better than the default set up.

    But….I've had to increase the security of my blog, and put an htaccess file into wp-content.
    All the file contains so far is

    1. Order Allow,Deny
    2. Deny from all
    3. Files ~ "\.(css|jpe?g|png|gif|js)$"
    4.  Allow from all
    5. /Files

    This breaks the menu. I tried adding

    1. Files "wp_ozh_adminmenu.php"
    2.  Allow from all
    3. /Files

    That doesn't work. If I delete the htaccess file the menu works fine again. Could you tell me what I need to add to the htaccess file to make it compatible with the menu?

  3. 1303
    Ozh France »
    wrote, on 27/May/10 at 8:51 pm # :

    steve » don't know

  4. 1304
    Jay United States »
    commented, on 31/May/10 at 8:40 pm # :

    Great plugin!

    However, same problem as Rakshit (21/Apr/10): "In Google chrome it shows menu in horizontal way. for e.g. setting tab, it shows long horizontal menu. So we need to scroll horizontally for looking at all pages. I have added two styles in "ozhmenu li ul" class which resolve this problem."

    Looking for those two styles, and also for integration into a future update.

  5. 1305
    Rich United States »
    thought, on 02/Jun/10 at 6:50 am # :

    Hey Ozh,

    Love the plugin…but having a problem, and only with upgrading. I'm running several blogs on my site, all up the 2.9.2 WP, but some have different plugin sets. My main site, and a few others, will not update thru WP plugin update, or Tools>upgrade functions.

    When I attempt to (and not update by FTP), the plugin upgrade brings me to my site's 404 page. Any idea why this might be? I've noticed this for the last few weeks. Otherwise, when I setup a new blog site, your plugin is always the first I activate, because it frees up so much screen space to give me some elbow room. Thanks for any comments back.

  6. 1306
    SVallie United States »
    replied, on 16/Jun/10 at 7:42 pm # :

    I absolutely LOVE this plugin, however the last two updates have broken the admin backside of the wordpress site.

    I use Chrome and WP 2.9+ [always the most current version available]. However, after installing today's update I'm getting this error:

    Fatal error: Call to undefined function get_admin_url() in wp-content/plugins/ozh-admin-drop-down-menu/inc/core.php on line 242

  7. 1307
    Ozh France »
    wrote, on 16/Jun/10 at 8:15 pm # :

    SVallie » as mentioned on this page, on the repository and in the readme.txt (arguably I forgot the plugin header, just fixed this) this is for WP 3.0+

  8. 1308
    Alex United Kingdom »
    commented, on 17/Jun/10 at 2:13 pm # :

    I also get error on upgrading. I appreciate that your latest version is for WP3 but I simply activated the auto upgrade on WP2.9 and it upgraded to the latest. Is there anyway you can either stop this or release it as a seperate plugin as most people won't bother to read that it is v3 only and their admin will break when the auto upgrade.

  9. 1309
    Ozh France »
    wrote, on 17/Jun/10 at 6:44 pm # :

    Alex » Yeah I thought WP 3.0 would be out sooner (this wednesday). I've added a check in the plugin to prevent activation on earlier versions of WP.

  10. 1310
    CarpetGuy United States »
    thought, on 17/Jun/10 at 8:39 pm # :

    Hello Ozh, I just upgraded and have found a red outline, 10px thick around the site URL in the admin menu, what is up with that? I have several sites, and not all of them have done this, when I inspect the element, here is the code

    1. #ozhmenu #oam_bloglink a {
    2. border:10px solid red;
    3. color:#FFFFFF;
    4. font-weight:bolder;

    Please tell me that there is a way to remove this, thanks

    David

  11. 1311
    Keith Conover United States »
    thought, on 17/Jun/10 at 10:17 pm # :

    Love the admin dropdown menu. Was running WP 2.9 and then did a mass upgrade of 16 add-ins and then, while trying to access my dashboard, I got this error:

    Fatal error: Call to undefined function get_admin_url() in /home4/edinform/public_html/wp-content/plugins/ozh-admin-drop-down-menu/inc/core.php on line 242

    Any suggestions on the least painful way to try to fix this would be appreciated!

  12. 1312
    Ozh France »
    replied, on 18/Jun/10 at 1:58 am # :

    Keith Conover » Delete and reinstall the plugin from the repository. I've fixed this. Or, better, upgrade WP.

  13. 1313
    Ozh France »
    said, on 18/Jun/10 at 2:02 am # :

    CarpetGuy » Must be some left over code I forgot there. Weird, I've never seen this rendered on the screen. I've remove them in the plugin, re-get it.

  14. 1314
    Lori United States »
    thought, on 18/Jun/10 at 2:12 am # :

    Upgraded to WordPress 3.0. today, unfortunately the drop down menu is not working. I even downloaded the plug-in again and re-installed but no luck. It shows up as a horizontal line instead of vertical.

    Bummer.

  15. 1315
    Sparanoid China »
    said, on 18/Jun/10 at 7:51 am # :

    When I use Minimal Mode to hide the header, it shows a red border around my site name:

    1. #ozhmenu #oam_bloglink a {
    2. border:10px solid red;
    3. color:#FFFFFF;
    4. font-weight:bolder;
    5. }
  16. 1316
    Ozh France »
    thought, on 18/Jun/10 at 11:20 am # :

    Lori » there's a test file in the /inc directory. Load it in your browser for a check & explanation of what fails.

  17. 1317
    CarpetGuy United States »
    thought, on 18/Jun/10 at 5:48 pm # :

    Thanks Ozh, I just removed the solid red from the .css, I am glad this was not on purpose, so, with the next upgrade it will stay gone. Again, thanks for my favorite plugin. Oh, I have to admit, I really thought the folks at WP would have gotten rid of that sidebar by now, guess I was wrong

  18. 1318
    Lori United States »
    wrote, on 18/Jun/10 at 6:13 pm # :

    Not sure if I did it right or not, but I just get a 404 page error. (http://www.laurelwreathsreflections.com/wp-content/plugins/ozh-admin-drop-down-menu/inc/test.html)

  19. 1319
    Ray Gulick United States »
    said, on 18/Jun/10 at 6:35 pm # :

    Just upgraded to WP 3.0, and the latest Ozh Admin Menu which is supposed to work with WP 3.0. The menu is broken, however. It just appears as a vertical list. Probably a CSS issue, but it's the same in both Firefox 3.6.3 and Chrome 5.0 (mac).

  20. 1320
    Lori United States »
    thought, on 18/Jun/10 at 6:37 pm # :

    Ray that is exactly what it is doing for me also.

  21. 1321
    Ray Gulick United States »
    thought, on 18/Jun/10 at 6:48 pm # :

    In fact, I just noticed that my admin area is displaying both the "standard" menu AND the vertical Ozh menu. So apparently, the Ozh menu is not replacing the standard admin menu.

  22. 1322
    Lori United States »
    said, on 18/Jun/10 at 6:52 pm # :

    Exactly mine also Ray

  23. 1323
    Ray Gulick United States »
    said, on 18/Jun/10 at 6:58 pm # :

    Here's a screenshot URL:
    http://evowebdev.com/ozh-admin-menu-problem.jpg

  24. 1324
    Ray Gulick United States »
    commented, on 18/Jun/10 at 7:01 pm # :

    Like you, Lori. I uninstalled and reinstalled, and still have the problem. Good to know I'm not the only one experiencing the problem.

  25. 1325
    Lori United States »
    wrote, on 18/Jun/10 at 7:02 pm # :

    That is what mine looks like to, good thing I am not the only one. =))

  26. 1326
    Paris Province France »
    said, on 18/Jun/10 at 7:35 pm # :

    Problem with update of Admin Drop Down Menu too on the french WP 3.0! Let's wait for a fix…

  27. 1327
    Ray Gulick United States »
    said, on 18/Jun/10 at 7:37 pm # :

    Waiting as patiently as I can. WP admin is ugly and more difficult to use without Ozh Admin Menu. ;-)

  28. 1328
    Andy Hodges United States »
    replied, on 18/Jun/10 at 8:38 pm # :

    Having the same problem as Lori and Ray … suffering withdrawal symptoms.

  29. 1329
    Thiago Brazil »
    thought, on 19/Jun/10 at 4:04 am # :

    Ray Gulick, same problem here !!!

  30. 1330
    Lee Rickler United Kingdom »
    said, on 19/Jun/10 at 4:07 pm # :

    Same here but I have done a few tests.
    On a straight upgrade or install to v3, the plugin works as normal.
    On a multi site install, the plugin fails.

  31. 1331
    Ray Gulick United States »
    thought, on 19/Jun/10 at 5:03 pm # :

    Mine is not a multisite install, still fails.

  32. 1332
    Ray Gulick United States »
    thought, on 19/Jun/10 at 5:58 pm # :

    It appears to me to have something to do with the reference to the stylesheet in the header. On a text page, if I remove all the garbage following "adminmenu.css.php", things seem to drop into place.

  33. 1333
    Ray Gulick United States »
    thought, on 19/Jun/10 at 6:01 pm # :

    That should have read "test page," and for some reason, code brackets no workie in comments. View the source, find the link reference, which shows this link with what looks like a lot of extra garbage:

    /wp-content/plugins/ozh-admin-drop-down-menu/inc/adminmenu.css.php?p=%2Fwp-content%2Fplugins%2Fozh-admin-drop-down-menu%2Finc&a=http%3A%2F%2Fevo2010.evowebdev.com%2Fwp-admin%2F&i=1&w=1&m=0&c=0&h=0&f=1&g=%23676768&n=0&d=left

  34. 1334
    Ray Gulick United States »
    wrote, on 19/Jun/10 at 8:16 pm # :

    Here's an interim fix, though it removes your ability to apply any settings:
    1. from the plugins editor, select "ozh-admin-drop-down-menu/inc/core.php"
    2. search for this string: /adminmenu.css.php?query
    3. delete "?query" and save the file.

    As I noted, this will remove your ability to apply any settings to the admin menu, but it allows you to use it.

  35. 1335
    Rich United States »
    thought, on 20/Jun/10 at 2:00 am # :

    Ozh,

    Still having issues with the menu system. Can't activate the plugin (v3.4). Backtracked to 3.3.10. Can't activate. Both versions give me the dreaded 404 error (www.domain.org/404) when either trying to activate, upgrade, edit within admin, etc. If I could get past this issue, possibly might be able to try Ray's fix below just to get it working again. Any ideas? Thanks…

  36. 1336
    Rich United States »
    replied, on 20/Jun/10 at 2:02 am # :

    Forgot to add, I am running wp 3.0, a slew of other plugins, and my own custom made them (created with Artisteer). Would that make ANY difference?

  37. 1337
    Ray Gulick United States »
    replied, on 20/Jun/10 at 2:35 am # :

    Here's a better fix (although it did not work for Rich):

    1. Delete most recent version of Ozh Admin Menu
    2. Download v. 3.3.1 (above) and upload to your plugins folder
    3. Activate it (viola!). You should have the Ozh Admin Menu you've grown to love.

    Rich, it sounds like you have some odd issues going on. I would suggest deactivating all plugins and reactivating one at a time to see if you can isolate a conflict. Your theme should not affect your admin area.

  38. 1338
    Rich United States »
    thought, on 20/Jun/10 at 5:37 am # :

    Ray, thanks…got it.

    I'm running a LOT of plugins, but using WP Super Cache, and the page load times are fine (under 3 seconds). Had to deactivate ALL of them…last one being Ozh' Absolute Comments . Trying to deactivate THAT one early in this process caused a 404 as well, until it was the last plugin to deactivate. Strange.

    So, deleted Admin menu folder, deactivated ALL plugins (I'll just say "over 100″), uploaded 3.3.11, activated it, UPGRADED IT to 3.4, using the auto upgrade feature, and Voilà…success. Reactivated MOST of the rest of the "recently active" plugins, and now Ozh menus are working PERFECTLY.

    I had thought about turning off ALL plugins days ago, but it was late, and I just didn't need it that bad. Now that it's done, I seem to remember having to do that a few plugin versions back for Admin Menu.

    Anyway, thanks to you Ray, and most especially to you, Ozh…this IS my favorite WP plugin of ALL I've used. Been hacking WP since 1.3 something or other…2005 at least.

    Rich

  39. 1339
    Steve Hall United States »
    commented, on 21/Jun/10 at 5:11 pm # :

    Having the same problem Ray is seeing. Unfortunately, re-upgrading from 3.3.1 to 3.4.1 didn't solve the problem.

    When this first occurred (when 3.4 was released, right after WP 3.0 came out) I wrote to Ozh, including a screenshot like Ray's. Ozh' response was that there might be 3 possible causes:
    (1) another plugin might be conflicting. So I disabled all but Drop-Down Menu. No joy.
    (2) A .htaccess entry might be causing a problem. So I removed my .htaccess file (it's now a 0-byte file). Again, no joy.
    (3) My hosting provider might be blocking php execution in some WordPress folders (e.g., /wp-content/ or /wp-content/plugins/). Filed a service report with my host (Arvixe.com) who promptly verified they do no php blocking at all.

    I'm using the Thesis premium theme for WordPress, but it has never, ever conflicted with a plugin before this. However, is anyone else having this issue also using Thesis?

  40. 1340
    Lori United States »
    said, on 21/Jun/10 at 5:14 pm # :

    Ray it worked for me. Thanks a bunch!

  41. 1341
    Ray Gulick United States »
    said, on 21/Jun/10 at 5:18 pm # :

    So this is interesting: I had an opportunity to do a new installation of WP this morning and, of course, installed WP3.0. I then added Ozh Admin Menu 3.4.1 (the one that has not been playing nicely with WP3.0 for me and others here) via the "add plugins" function in the admin area. It works fine.

    Is it possible it's only a problem on sites that have been upgraded to 3.0 while Ozh Admin Menu is activated?

  42. 1342
    Lori United States »
    wrote, on 21/Jun/10 at 5:25 pm # :

    Well for me Ray, I have two sites and what is funny is it did not work on the one where I deactivated all the plug-ins.

    ON the second site I just kept the plug-ins active and they all worked (including Ozh Admin Menu 3.4.1. Go figure.

  43. 1343
    Ray Gulick United States »
    thought, on 21/Jun/10 at 5:32 pm # :

    Kind of hard to see a pattern in each of these cases that's helpful…

  44. 1344
    Steve Hall United States »
    replied, on 21/Jun/10 at 5:35 pm # :

    I've tried each suggested solution; unfortunately, nothing has worked. The only thing I have not tried is to upgrade to WordPress 3.0 (again) after removing Ozh Admin Menu. Not even sure HOW to do that, though, since 3.0 is active on my site now.

  45. 1345
    Ray Gulick United States »
    thought, on 21/Jun/10 at 5:39 pm # :

    Steve – So, going back to Ozh v.3.3.11 and using that (not upgrading to most recent Ozh menu) didn't work for you?

  46. 1346
    Steve Hall United States »
    said, on 21/Jun/10 at 5:43 pm # :

    Ray – Sadly, no. I just did it once more, after completely removing the Ozh Admin Menu folder. I get the same vertical menu listing that I get with 3.4.1.

    Starting to think a virgin WP install may be my only hope…and really not looking forward to doing that. I supposed I could simply remove all my WP files then treat it as a new installation…but I really REALLY like the control of a semi-automated installation process.

  47. 1347
    sam Canada »
    replied, on 22/Jun/10 at 6:06 am # :

    I can't remove the admin bar, keeps saying there is a folder created already. Can anyone help,
    thanks
    Sam

  48. 1348
    Ray Gulick United States »
    wrote, on 22/Jun/10 at 3:39 pm # :

    Sam – Did you try accessing your plugins folder via FTP and dragging the ozh-admin-drop-down-menu folder to the trash?

  49. 1349
    Rich United States »
    replied, on 22/Jun/10 at 4:01 pm # :

    Steve,

    In certain versions of IE(even different builds of v7, for example), I seen the vertical menu instead of the correct horizontal display. I've seen in both v6 and v7. Using FireFox or Chrome, the admin menu displays correctly. Try switching browsers to see if that makes a difference.

  50. 1350
    Steve Hall United States »
    commented, on 22/Jun/10 at 5:47 pm # :

    Rich – I use Chrome exclusively (and I'm on a Mac, as well). I was able to resolve the issue by uninstalling WP 3.0, reinstalling it, and installing Ozh Admin Menu as my first add-on. Now, everything is peachy.

    Just very strange that it would take such drastic measures on a pretty vanilla installation.

Pages: « 122 23 24 25 26 [27] 28 29 30 31 3233 » Show All

Leave a Reply

Comment Guidelines or Die

  • HTML: You can use these tags: <a href=""> <em> <i> <b> <strong> <blockquote>
  • Posting code: Post raw code (no <> &lt; etc) within appropriate tags : [php][/php], [css][/css], [html][/html], [js][/js], [sql][/sql], [xml][/xml], or generic [code][code]
  • Gravatars: Curious about the little images next to each commenter's name ? Go to Gravatar.
  • Spam: Various spam plugins on patrol. I'll put pins in a Voodoo doll if you spam me.
  • I will mark as Spam test comments, all comments with SEO names (ie "My Cool Online Shop" instead of "Joe") or containing forum-like signatures.